Проблемы после сборки

Тема в разделе "Помощь в устранении неисправностей", создана пользователем TonitoC, 8 мар 2018.

  1. sashokc

    sashokc Новый пользователь

    Приветствую, собирал БП вроде бы все норм, кроме как измерение тока работает в обратную сторону. Когда даю нагрузку вместо того что бы расти ток падает. Соответсвенно если я резистором выставляю в ноль то ток перестает измерять вообще.
     
    Последнее редактирование: 12 июн 2018
  2. Gupic

    Gupic Moderator Команда форума

    "Забавный" случай...
    А можно немножко поподробнее? что вообще показывает без нагрузки? Если можно - то скиньте пару фоток.
    Обязательно поможем!
     
  3. sashokc

    sashokc Новый пользователь

    Напряжения на Q3
    1 нога 1,069
    2 нога 0,386
    3 нога 0,384

    На ардуинке пин A0 0.387

    Пробовал 2SC945 Вместо BC547. Результат такой же. Так же пробовал разные LM358 - LM358N

    Помогает только инвертирование 0 аналогового пина в скетче и то показания не корректны:

    float Iout = (1023-analogRead(A0)) / 100.00; // узнаем ток в нагрузке

    Уже столько раз перепаивал плату, начали дороги отслаиватся от текстолита.(
     

    Вложения:

    Gupic нравится это.
  4. sashokc

    sashokc Новый пользователь

    Я уже думаю может запилить измерение тока через модуль ACS712? :)

    Промоделировал в Proteus. Довольно таки корректно работает.
    Придется внести немного поправочных коэффициентов и будет гуд)
     

    Вложения:

    Последнее редактирование: 13 июн 2018
  5. Gupic

    Gupic Moderator Команда форума

    Насколько я понял, третья нога это эмиттер. И на нем, напряжение чуть меньше чем на пине 0, который является входом
    сигнала о токе в нагрузке. А значит, что что-то не так с этим пином. Попробуйте заменить его на А2 или А3, указав выбранный пин в скетче.
    Для этого замените А0 в строке "float Iout = analogRead(A0) / 100.00; // узнаем ток в нагрузке".

    ИЛИ

    Попробуйте подставить другую ардуинку.
     
    sashokc нравится это.
  6. sashokc

    sashokc Новый пользователь

    Спасибо, я тоже подозреваю ардуинку, потому как аналоговые пины уже пробовал менять.

    Но все таки для себя остановился на ACS712 не знаю буду ли что то менять. Точность до сотых радует.
     
  7. Gupic

    Gupic Moderator Команда форума

    Ну вы это... Поделитесь с миром если что. Авось кому пригодится Ваш опыт!
     
    sashokc нравится это.
  8. maladchaga

    maladchaga Новый пользователь

    Парни, помогите. Я слаб в элетронике, но так хотелось приобщится...)) От моих экспериментов ардуинка устала и задымела. Из-за корпуса решил разделить схемку на две платы и развести дорожки своими руками. Ардуино с разъемами для экрана и минимальной обвязкой на одной плате, все остальное отдельно. Скетч заливал русифицированый с форума и все казалось чудесным до самого последнего момента - когда подключил силовой транзистор. Ардуино почему задымела и умерла. Может и экран почил - еще не проверял. Напряжение на дорожках, идущих на пины ардуино, было 12 В. Как такое могло произойти? Как обезопасить ардуино в дальнейшем? У меня еще одна нано есть, но теперь как-то стремно ее подключать.
    Снимок.JPG FJIMG_20180802_070324.jpg FJIMG_20180802_070400.jpg
     
  9. Gupic

    Gupic Moderator Команда форума

    Однозначно ошибка в монтаже, может соплю где-то оставили или что-то в этом роде.
    И да. Что конкретно задымело в Ардуино? МК?
     
  10. maladchaga

    maladchaga Новый пользователь

    Честно говоря, откуда пошёл дымок я не видел. МК визуально целый. Светодиоды горят, но комп не видит... А плату я подключал к питанию постоянно для проверки. Последний этап был, когда все детали запаяны, но без транзистора. Подключил - ничего не коротило, меню работало, реле щелкало. А вот когда воткнул транзистор и подал питание... Есть нюанс, что запитывал от ИБП на 24В...
     
  11. Gupic

    Gupic Moderator Команда форума

    Ну не знаю проверьте питание на МК. Схема во вложении. Может линейный стабилизатор вылетел. (у меня так было из-за КЗ)
     

    Вложения:

  12. maladchaga

    maladchaga Новый пользователь

    Скажите, а ниоткуда не могло прилететь на входы напряжение больше 5В? Может можно входы защитить стабилитроном каким-нибудь? Повлияет ли это как то на работу? Или все же смотреть на питание? Я вот думал после LM7812 (или вместо нее) поставить регулируемый китайский DCDC преобразователь, чтобы на VIN подавать вольт 7-8. Многие пишут, что для встроенного стабилизатора 12 В многовато. Мой мультиметр китайский показывает что напряжение после лмки 12.3 В.
     
  13. witt84

    witt84 Новый пользователь

    Была тоже проблема, с показаниями тока в обратную сторону(вместо BC546 стоял 2SC945), поставил на места Q1 и Q3, 2 идентичных транзистора кт815в, И все стало работать нормально. Только нужно соблюдать цокалевки. У транзисторов BC546 и КТ815 они отличаются.
     
    Последнее редактирование: 26 окт 2018
  14. вячя

    вячя Новый пользователь

    Доброго времени суток . Немогу понять не как у меня вообще тока не меряет. Пробовал менять и пини на ардуино нано, и ОУ. Нечего не получается.
     
  15. witt84

    witt84 Новый пользователь

    А шунт какой? И рабочий ли транзистор Q3?
     
    Последнее редактирование: 1 ноя 2018
  16. вячя

    вячя Новый пользователь

    Шунт фабричный. На 10 ампер. 75шсм3-10-0.5. Я пробовал ставить резисторы ставить керамические 0.1, 0.5 Ом и пробовал 1.5 Ом. Начало показывать но не надолго резистор роскалился до красна 1 амперметре.
     
  17. Oleg_D

    Oleg_D Интересующийся

    Судя по всему, Вам надо увеличить усиление раз в 10 подбором R8 и R7. Сорри за опоздание.
     
  18. вячя

    вячя Новый пользователь

     
  19. Oleg_D

    Oleg_D Интересующийся

    Почитайте здесь:
    http://arduino.ru/forum/programmirovanie/datchik-toka-acs712 , а конкретно:
    http://arduino.ru/forum/programmirovanie/datchik-toka-acs712#comment-333387
    Скетч тоже там есть. В общем - исходите из того, что чувствительность датчика 185мВ/А. В скетче ничего особенного делать не надо, простая математика. Я бы делал на двух модулях по встречно- параллельной схеме, как в теме выше. Но все равно нужен либо ads1115, либо с помощью ОУ усилить сигнал до 5 В и сместить на 2.5В до нуля. Иначе пол диапазона чувствительности МК( которая и так не ахти) пропадет даром.
     
  20. вячя

    вячя Новый пользователь

    Я даже и не поднемал этот вопрос. Просто я так не добился не какого адекватного измерения тока. Поменял ОУ на lm2904n начал шкалить и уходить в перегруз. Вот и решил поставить датчик ACS 712
     

Поделиться этой страницей